• Severity Rating • Fix Information • Vulnerable Software Versions • SCAP Mappings
Buffer overflow in Berkeley parallel make (pmake) 2.1.33 and earlier allows a local user to gain root privileges via a long check argument of a shell definition.
Note: References are provided for the convenience of the reader to help distinguish between vulnerabilities. The list is not intended to be complete.
Date Entry Created
20020131 Disclaimer: The entry creation date may reflect when the CVE-ID was allocated or reserved, and does not necessarily indicate when this vulnerability was discovered, shared with the affected vendor, publicly disclosed, or updated in CVE.
Phase (Legacy)
Modified (20050703)
Votes (Legacy)
ACCEPT(1) Baker
MODIFY(1) Frech
NOOP(4) Armstrong, Cole, Foat, Wall
Comments (Legacy)
 Frech> XF:pmake-shell-bo(7603)
 Baker> A check of the latest version of pmake, version 2.1.36 reveals that the author lists the format string error as having been corrected.
   This should be sufficient for vendor acknowledgement.

Proposed (Legacy)
This is an entry on the CVE list, which standardizes names for security problems.