• Severity Rating • Fix Information • Vulnerable Software Versions • SCAP Mappings
Buffer overflow in WFTPD Pro 3.00 allows remote attackers to execute arbitrary commands via a long CWD command.
Note: References are provided for the convenience of the reader to help distinguish between vulnerabilities. The list is not intended to be complete.
Date Entry Created
20010404 Disclaimer: The entry creation date may reflect when the CVE-ID was allocated or reserved, and does not necessarily indicate when this vulnerability was discovered, shared with the affected vendor, publicly disclosed, or updated in CVE.
Phase (Legacy)
Proposed (20010404)
Votes (Legacy)
ACCEPT(2) Baker, Cole
MODIFY(1) Frech
NOOP(2) Wall, Ziese
RECAST(1) Prosser
Comments (Legacy)
 Frech> XF:wftpd-pro-cwd-bo(6184)
 Prosser> See for additional info on this one.  It looks like Can-2001-0296 may be a continuation of CVE 1999-0950.  Appears from ref that this problem has been in every version since the 2.40 problem reported Oct 1999 (CVE 1999-0950).  Just managed to change the code so it requires more characters to overflow the buffer.  I haven't tested this, but just from the available documentation, these problems look like a continuation of the early one.

Proposed (Legacy)
This is an entry on the CVE list, which standardizes names for security problems.