CVE-ID

CVE-1999-1158

• Severity Rating • Fix Information • Vulnerable Software Versions • SCAP Mappings
Description
Buffer overflow in (1) pluggable authentication module (PAM) on Solaris 2.5.1 and 2.5 and (2) unix_scheme in Solaris 2.4 and 2.3 allows local users to gain root privileges via programs that use these modules such as passwd, yppasswd, and nispasswd.
References
Note: References are provided for the convenience of the reader to help distinguish between vulnerabilities. The list is not intended to be complete.
Date Entry Created
20010831 Disclaimer: The entry creation date may reflect when the CVE-ID was allocated or reserved, and does not necessarily indicate when this vulnerability was discovered, shared with the affected vendor, publicly disclosed, or updated in CVE.
Phase (Legacy)
Proposed (20010912)
Votes (Legacy)
ACCEPT(4) Cole, Dik, Foat, Stracener
MODIFY(1) Frech
RECAST(1) Christey
Comments (Legacy)
 Frech> XF:solaris-pam-bo(7432)
 Dik> sun bug: 4018347
 Christey> These issues should be SPLIT per CD:SF-EXEC because the PAM
   problem appears in different Solaris versions than
   unix_scheme.

Proposed (Legacy)
20010912
This is an entry on the CVE list, which standardizes names for security problems.