• CVSS Severity Rating • Fix Information • Vulnerable Software Versions • SCAP Mappings • CPE Information
Multiple buffer overflows in apcupsd before 3.8.6, and 3.10.x before 3.10.5, may allow attackers to cause a denial of service or execute arbitrary code, related to usage of the vsprintf function.
Note: References are provided for the convenience of the reader to help distinguish between vulnerabilities. The list is not intended to be complete.
Assigning CNA
MITRE Corporation
Date Record Created
20030221 Disclaimer: The record creation date may reflect when the CVE ID was allocated or reserved, and does not necessarily indicate when this vulnerability was discovered, shared with the affected vendor, publicly disclosed, or updated in CVE.
Phase (Legacy)
Modified (20071016)
Votes (Legacy)
ACCEPT(4) Armstrong, Cole, Green, Jones
NOOP(2) Christey, Cox
Comments (Legacy)
 Christey> SUSE:SuSE-SA:2003:022
 Christey> DEBIAN:DSA-277
 Christey> As observed in an email to us by a third party, it appears
   that 3.8.6 is probably not affected by this, so the
   description should be changed to refer to "3.10.x before
   3.10.5, and 3.8.x before 3.8.6".
 Christey> An email from Kern Sibbald on August 21, 2003, confirmed that
   3.8.6 and 3.10.5 fixed the issue.

Proposed (Legacy)
This is an record on the CVE List, which provides common identifiers for publicly known cybersecurity vulnerabilities.